Could Not Load File or Assembly CLI.Implementation

14 posts / 0 new
Last post
 
Could Not Load File or Assembly CLI.Implementation

I recently got a new PC, preloaded with an onboard graphics card that. The graphics card works fine except for the fact that it won't let me adjust the DVI frequency for my LCD (21") monitor. It's running in 1600x1200 resolution, and every now and then there's screen artifacts, flickr, or drop-outs of the picture.

In the past the only way I found to solve this was to use an ATI card, and within the Catalyst Control center, set "alternate DVI mode" and "reduce DVI frequency on high resolution displays."

So I've got my new ATI card now (wasn't very expensive), but whenever I try to install the latest Catalyst Control center (v 9.2) for my card (ATI Radeon HD4350), I run into all the darn Implementation errors:

  • Could Not Load File or Assembly CLI.Implementation
  • Could Not Load File or Assembly CCC.Implementation
  • Could Not Load File or Assembly MOM.Implementation

I've read in your community site that the fix is to install MS .NET framework version 1.1 alongside 2.0, but my PC only has 3.5 SP1 installed. Any ideas how to get the ball rolling on this one?

No votes yet
 
Select your preferred way to display the comments and click "Save settings" to activate your changes.
Catalyst Control Center is associated with a different version o

These CLI, CCC, and MOM.implementation errors have to be some of the most common on the web. The basic problem is that each version of Catalyst Control Center is associated with a different version of the .NET framework - and since the frameworks are not cumulative, you may need to install past frameworks to get Catalyst to install correctly.

Here's the best way to proceed, regardless of the version of Catalyst you're installing, and regardless of the versions of .NET framework you already have installed:

  • Uninstall ATI's Catalyst Control Center
  • Using Add/Remove Programs - uninstall each version of the .NET framework
  • Use the Windows Installer Cleanup Utility to clean up the Windows MSI (installation) database and erase any traces of the frameworks
  • Restart your PC
  • Download and install each of the .NET frameworks listed on this page in order: http://support.microsoft.com/kb/923100
  • Reinstall the latest version Catalyst Control Center from amd.com matching your graphics card specs


If for some reason that doesn't work, you might need to uninstall Catalyst Center, remove all keys from the C:/Windows/Assembly folder that contain the following public key token: 90ba9c70f846762e[/*], and then re-install Catalyst.

Also try installing the Catalyst standalone (without the display and integrated drivers).

Any Luck?

Anyone try this?

Uninstall Catalyst Center

In case somebody still has an issue with this, I followed the final piece of advice only and it worked a treat. i.e. ......

you might need to uninstall Catalyst Center, remove all keys from the C:/Windows/Assembly folder that contain the following public key token: 90ba9c70f846762e[/*], and then re-install Catalyst.

Also try installing the Catalyst standalone (without the display and integrated drivers).

... problem was solved in about 5 minutes. Thanks WRYW.

Worked

Yes it really works, only follow the steps.

Assemblies

I can't delete the assemblies!

Great work!

I could kiss you WRYW.

This (1) solved some annoying MOM.implementation startup error message that has been nagging me for months, and (2) fixed a problem with running Civ5, thereby letting me enjoy my birthday present!

Bless you for saving this village, WRYW! Bless you!

Excellent

I love you so much. you ended my 14 hour torment to fix the VGA driver. Be good my friend. smiley

Thanks

It works for me, thanks.

Worked

Worked for me, didn't need to touch Assemblies.

Can't delete CCC

I have the same problem but don't know how to delete ccc. Please help me through the process.

This solved it!

Wow, I've been searching the internet all night and WRYW's post is the only one that was both relevant and solved my problem. Thank you very much and keep on keepin' onsmiley

No luck

Hi, I did everything you wrote, but it still doesn't work. What should I do? Thanks!

Muchas Gracias

It worked for me!!!! And only with Assemblies step. Muchas Gracias!!! Saludos desde México.

The content of this field is kept private and will not be shown publicly.
 

We use this trick question to try and prevent automated spam comments.