We Rock Your Web in the Press!

How do I disable the welcome screen in Windows XP?

Home Forums Tech Troubleshooting How do I disable the welcome screen in Windows XP?

Post a New Topic

This topic contains 30 replies, has 6 voices, and was last updated by  Kimberly Kurimski 1 year, 6 months ago.

  • Author
    Posts
  • #10632

    AndyGregory
    Member

    How can I get Windows XP to automatically login?

  • #10634

    Alex Schenker
    Keymaster

    Prefer that Windows XP would simply automatically log on? You’re not the only one. The welcome screen, on a PC with only one user, is quite useless. To disable it, first browse to Control Panel -> User Accounts (via classic control panel view), and delete all but the main and guest accounts.

    Next you’ll want to select “Change the way users log on or off” and uncheck “Use the Welcome screen.” This will also automatically uncheck “Use Fast User Switching” as well. Finally, you’ll want to browse to Start -> Run and type in the following:

    control userpasswords2

    Uncheck “Users must enter a username and password to use this computer” – you may then choose to store a password or proceed with no password. Click “OK” to save your changes.

    Important Note for ASP.NET Users

    If you have the ASP.NET framework installed, deleting the ASP.NET administrator will cause issues. This account was created with limited permissions for security purposes, but if you disable it your .NET applications may not work correctly. If you need to restore the account for any reason, you may do so by browsing to Start -> Run, and typing the following command:

    %systemroot%\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis.exe /i

    Make sure to replace v1.1… with the .NET framework version you have installed.

  • #11291

    Guest
    Participant

    Cannot log onto Windows XP now. I mistakenly deleted the asp.net user. I rebooted and now my machine will not let me log on! I’m sweating right now. How do I get back into my machine to fix this? Please help.

  • #11292

    idefix
    Member

    I read your article on how to disable the welcome screen in Windows XP. I deleted asp.net, rebooted and cannot get past the log on part. Hence I cannot get back into my computer and I’m locked out. I get a big BLEEP when the PC starts up. It does say not to delete this, so it’s my fault. Please tell me there is a way to save my set up. Please oh please.

    Thanks in advance,

    DHG

    • #11293

      Alex Schenker
      Keymaster

      Hi DHG,
      When you say you cannot get past the log on part – you can’t log in because you don’t know the user name/ password? The ASP.NET user is created when you install the ASP.NET framework – if you delete the user the Windows logon should return to normal and you should be able to log in as the default Windows admin.

      If you’re using ASP.NET 1.1, the new ASP.NET user will prevent auto logon. Upgrade your ASP.NET framework to resolve this.

  • #11294

    idefix
    Member

    Thank you for your time. When I power up, I get the log on to Windows screen. Immediately another window pops up “unable to log you on because of an account restriction” I hit OK button, then it brings me to the log on to Windows screen without the error. I can try to log on as the administrator however I never set any password for this as it is just my home computer for which I use to record music. So essentially I have no idea what the administrator password is as I never set one. DOH! What do I do? I have only two different passwords that I use and I have tried all different combinations for it, but still cannot log on. : ( I feel like a child who realizes mom ain’t home and the door is locked. Hah!
    DHG

    • #11295

      Guest
      Participant

      When you get to the Administrator login where it asks for the Administrator password, have you tried just hitting “enter”? If you never set up a password, it should just take “enter” and let you log on.

  • #11296

    idefix
    Member

    Ok, it does allow me to log on as administrator, however I never set a password for the administrator, and I have no idea what that password might be. It’s my private computer at home you see. Is there possibly a default password that Windows XP sets?
    Thanks
    deephousegroove

  • #11298

    idefix
    Member

    I cannot log in as administrator, as it demands a password. I never set a password as this is my personnel computer at home. Is there possibly a default administrator password that Windows XP sets? If I cannot log in will I be able to reinstall asp.net? Do I need to just load up the Windows XP install disk and maybe it will automatically load it up for me. Sounds too easy, so I would assume not. Please help as I have not been able to log onto my computer in over a week now.

    Thanks DHG

    • #11299

      Alex Schenker
      Keymaster

      Hi DHG,

      Seeing as no one as been able to offer suggestions to help you out (and I’m stumped) I suggest you seek local tech support or search Windows XP forums to help you resolve this.

  • #11300

    Guest
    Participant

    From the Start Menu, choose “Run…”

    Type: control userpasswords2 into the box. Use the displayed screen.

  • #11301

    Guest
    Participant

    HOW TO DISABLE THIS COMMAND control userpasswords2 in admin acct. Also, I want to disable nusrmgr.cpl , gpedit.msc Please need help….

    Thanks,

    WEEBMASTER

  • #11303

    Guest
    Participant

    Upgraded to Vista and the welcome screen situation is even worse. I’m going to switch to a variant of Linux – tired of this crap.

  • #11304

    Guest
    Participant

    I am not getting the welcome screen.

  • #11305

    Guest
    Participant

    How are you to do these things when the computer won’t let me in to begin with because I can’t remember the password?

  • #11306

    Guest
    Participant

    Go to the Start menu and click the Run box, type in “regedit”

    Navigate via the left pane on the regedit window that opens to the following key:[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]

    Then change these entries and reboot.
    “DefaultUserName”=”yourname”
    “DefaultPassword”=”yourpassword”
    “AutoAdminLogon”=”1″

    Replace “yourname” and “yourpassword” with current users details.

    If you can’t log onto Windows because of forgotten password try a boot CD like Hirens and use the password tools on it. Or you could try the “Ultimate Boot CD” which has a remote registry editor.

    • #11307

      Guest
      Participant

      Thank you. Even though I knew if I had the welcome screen enabled I wouldn’t see this stupid login box with the old owner’s name on it; I still wanted it changed to my name. Thank you again, so, so much! Now, I’m off to enable the welcome screen again, haha!

  • #11308

    Guest
    Participant

    Thanks for your help buddy.

  • #11309

    Guest
    Participant

    The people who are trying to help on this subject simply don’t read the posts from users here. They CAN’T CHANGE THEIR SYSTEMS IF THEY CAN’T LOGON TO BEGIN WITH!!

    People, just use the available options on your screen to RESTART your computer and boot it into SAFE MODE. When the computer restarts just keep tapping on the F8 key (Dell computers are CTRL or DEL key, I forget) to bring up the black logon options screen and select SAFE MODE using your up/down arrow keys. You will be able to change your settings back to what they were in safe mode. Reboot your computer and see if it works normally. If not, restart and log back into safe mode again and go back and see what you missed when changing back to your original settings.

  • #11310

    Guest
    Participant

    Well I suppose you could go crazy and use browser support for opacity to do that. But it would probably slow it down even more.

  • #11302

    Guest
    Participant

    Hi,
    I followed the directions above and disabled the Welcome Screen. The problem is that when I turned on the computer next time, it logged me in on the administrator account without any option to change it to my account (user account). I had to re-activate the Welcome Screen and also check “Use Fast User Switching” to get back to the user account.

    Now, every time I turn on the computer it logs me in on the administrator account and I have to log off and choose my user account, which is even more of a nuisance than just having the Welcome Screen. I have disabled the guest account, but there is no option given to turn off the administrator account. (There are actually two accounts named administrator account. One of them is the one that says asp.net, and the instructions above said not to disable that account).

    Thanks

  • #11312

    Guest
    Participant

    Tried what’s suggested here, and yes it works; even though the welcome screen disappears, still get that login prompt window w/ administrator to have to click on. That logs me on, but would rather have nothing to deal with. Have another Windows XP system that bypasses both welcome screen and admin prompt login window but do not know how it occurs. The Windows Logo boots up w/ the green traveling bar and then goes right to my desktop. Someone got that system working that way but I don’t know how to do it…anyone know how? I’d like to set up another system to do the same.

    Thx for any tips.

  • #11313

    Guest
    Participant

    Hello,

    The suggestions given by disabling the welcome screen function and by typing in ‘control userpasswords2′ seemed to work but still gave me the admin login prompt. Would like to dump both the welcome screen and admin prompt window…just want it to boot up from Windows Logo XP and jump to the desktop.

    Anyone with suggestions how to do that?

    Thanks for any tips!

    • #11314

      Guest
      Participant

      By typing in ‘control userpasswords2′  in the cmd box works so after you have unchecked the “users must enter a password” box, you will get the box with administrator and the passwords. Make sure to change the administrators name to your login name and match the password to your own if you have one. If you have not set up a password, do not enter one this should do the trick. Hope this sorts it for you.

  • #11315

    Guest
    Participant

    Would like to dump both the Welcome Screen and the Admin User Login Prompt so as not to be bothered w/ either. Just want to boot and go to the desktop. Does anyone know how I can set this up???

    Appreciate any tips! Thx!

  • #11316

    Guest
    Participant

    Submitted early query this morning for help w/ this issue. Tried all suggested here on site w/ struggles but an excellent learning experience via trial and error. Managed to find my own answer to the question for which I was searching.

    To bypass the annoying ‘must click a user name’ on welcome screen w/ user accts listed, ie., administrator, guest, etc. without having to click on any acct, just go to ‘Control Panel’ > ‘change the way users log on and off’ > then uncheck the ‘Use Fast User Switching’ box and select ‘apply changes’ button below.

    As far as the Start, Run, Type ‘Control Userpasswords2′ in order to go to the User Acct Window, the box needs to be checked for ‘Users must enter a user name and password to use this computer’ but I found that if the names below representing users were left unhighlighted and clicked the ‘okay’ button below then everything works perfect. No prompt appears…that screen just goes away! When restarted, computer boots w/ Windows XP Logo, jumps to a ‘Welcome screen’ but with no user names to click on then just goes automatically to the desktop. So, the welcome screen shows up but without names to bother clicking and no admin user prompt login window, then jumps to the desktop. PERFECT!!! Simple, no hassles, no problems…just click on system and go! I would NOT have figured this out without locating your site on the net. And too, without all your comments, so…THANK YOU ALL for your input…it gave me a springboard to start my trial and error process until I discovered what I was seeking. So, of course I wanted to share w/ you all. Sorry for the lengthy words…but didn’t know how else to say it except how I did. Happy computing all!!!

    • #11317

      Guest
      Participant

      Thanks! Your comments worked in reverse as well. I WANTED the admin screen NOT to come up after reboot automatically! Using “run” “user passwords2″ worked!!

      Thx
      Tom

  • #11318

    Guest
    Participant

    Thanks for your quick and easy tutorial on combating a simple problem with a less-than-obvious solution. I appreciate you taking the time to write something like that. Please don’t stop using your knowledge to make the world a little less stupid!

  • #11319

    Guest
    Participant

    The Windows XP Welcome screen is set to appear by default every time you restart your computer. The screen displays user accounts on the computer, and if you click on the icon belonging to your user name, it allows you to log in with your user name and password.

  • #11320

    a web rocker
    Member

    People keep mentioning not wanting to login using admin/username & password. Well here’s the thing..YOU WANT/NEED TO USE YOUR ADMIN or USERNAME & PASSWORD WHEN LOGGING ON. Why? Because it is part of “Windows Security”. THIS SECURITY LOGON METHOD IS TITLED “CLASSIC LOGON”. THE OTHER LOGON IS DONE FROM THE “WELCOME SCREEN” & THIS IS THE DEFAULT LOGON MODE FOR WINDOWS XP & OFFERS NO REAL SECURITY. You might say this is annoying but u need to think about it..the welcome screen logon simply means the system maintains unique user environments or profiles between which it can easily switch. Classic logon screen u may have seen in other Windows versions by pressing Ctrl+Alt+Del twice while the welcome screen is showing, & this is the secure logon method for accessing the machine you’re using. Classic logon can be done by default..where the system has to be configured thru the USER ACCOUNTS Applet. Remember, logon credentials required for ‘secure logon’ are “username & password”. Also, the logon location on Windows xp is always local only, meaning it does not support domains used in large networks like corporations. So u do need a user account to logon, if u don’t have one then go to secure logon screen & logon using administrator account..which is your own name & password. The classic logon method is labeled secure for 2 specific reasons: 1) u must always provide a password (a blank one can be assigned but will be an insecure account). 2) u must provide a valid username. / By default the last username to logon & use the system will be displayed but will be the only user account u get to see. This is totally unlike the Welcome logon screen, which openly displays the names of all defined user accounts. So…get used to the nature of the beast whether u are using a machine by yourself or with others.

    • #11321

      I just think it’s important to understand that with physical access you can password protect your stuff until the cows come home but with a simple boot cd you can easily get past any password. So I feel your argument is invalid for this particular reason.

You must be logged in to reply to this topic.