What is this? Error (1603): Fatal error during installation

What does this error mean and why am I getting it? Aborting Installation: Error (1603): Fatal error during installation

Know the answer? Comment below! Got your own question? Ask it here.

4
Leave a Reply

avatar
newest oldest most voted
guest
This error message is displayed by the Microsoft Windows Installer via the Comodo Internet Security engine and is a general error code that indicates a problem occurred during the installation.
guest
Well I think it depends on the computer and its components. Perhaps you should call remote computer assistance for more help.
guest
Thanks for the tips. For me it was a permissions issue. Actually, I had run the installer as an “administrator”, thinking it would automatically receive the necessary privileges, but that somehow screwed everything up. What ended up working was simply right-clicking the installer and installing my program (Adobe Creative Suite CS4) into the recommended installation folder.

Hope this helps someone else!

Alex Schenker (Admin)
The 1603 error is restricted to the Windows operating system. It occurs when a program fails to install correctly, and is reported to be seen commonly with Corel (Creative Suite, Photoshop), Intuit, etc. software. The problem is most commonly a result of three situations:

  • You don’t have administrative privileges (solution: log back in as administrator)
  • The folder you’re trying to install to is encrypted or protect it (solution: unencrypt or unprotect it)
  • You’re trying to install the program to a substitute drive. (solution: install the program to a primary drive.)

If you are logged in as administrator and still getting the 1603 aborting installation error, you’ll want to make sure you grant your user full permission (in Windows 7, right-click the folder your program is being installed to, and select Properties > Security tab > Administrators (or SYSTEM for Windows XP/2000) > and grant that user full permissions).
Anti-Spyware Software
According to reports we’ve received, this error is common in some anti-spyware software as well, especially earlier iterations of the Webroot Spy Sweeper. We found the highly touted Webroot Spy Sweeper to be extremely buggy. For reference, we installed version 6.0.2.39 at the time of this writing. For starters, in order to even get Spy Sweeper installed, we had to download a SafeCore.exe file from their website (or start Windows XP in safe mode) to even get the software to install. If we didn’t do this, and simply ran the installer, we would encounter the message: Aborting Installation: Error (1603): Fatal error during installation every single time we tried to install.
Webroot’s Spy Sweeper is buggy all the way through
Once we got past this, the software appeared to be running fine, but only for the first few minutes. Shortly after getting Spy Sweeper up and running, it froze up our entire computer during a routine scan. We attempted to pause the scan, which may have caused the problem – but then again, anti-spyware software needs to have a pause function that works during scanning, or what good is it.
Spy Sweeper appears to conflict with existing security software
Finally, every time we reboot our computer we would run into troubles. Random crashes, task manager not loading, Control Panel not loading, and apparent conflicts with Online Armor that would cause Online Armor security messages to repeat over and over again. Finally, we weren’t even able to shut down the Spy Sweeper software – it would crash when we tried to do that.
Spy Sweeper’s Free Beta Testing Version
As a final insult, when we finally succeeded in uninstalling the software via Windows Add/ Remove Programs (the first try failed), a Webroot (the Spy Sweeper developer) web browser window was launched, containing the message Did you think Spy Sweeper was free? and a link to to their TrialPay (beta testing, we’re assuming) program, which apparently cost nothing. Why would we want to risk our computer testing buggy beta software, if the original software won’t even function?

We were hoping to receive a window where we could give them feedback and describe our issues, but apparently they’re not interested. For such heavily touted security software (#1 ratings for spyware removal in some publications), we’re heavily disappointed in our experience using Webroot’s Spy Sweeper. We only hope that they are able to iron out these wrinkles and compatibility issues in the event that we give them another try in the future.
Still Need Help with “Aborting Installation: Error (1603): Fatal error during installation”?
If you’re still having trouble with this error and none of the above suggestions helped, please comment below with details and we’ll do our best to help you troubleshoot.