Clipboard Cannot Be Emptied

I’m trying to copy information out of a cell in MS Excel 2010, and I keep getting the error “The clipboard cannot be emptied. Another program might be using the clipboard.”

WTF? I’m not trying to empty the clipboard, I’m simply trying to copy data so I can paste it elsewhere. Needless to say, it doesn’t appear to be copying anything. I’ve never had this problem before and it’s incredibly annoying. Any ideas?

Know the answer? Comment below! Got your own question? Ask it here.

17
Leave a Reply

10 Comment threads
7 Thread replies
0 Followers
 
Most reacted comment
Hottest comment thread
17 Comment authors
newest oldest most voted
Tiff
Hi, This error message has been annoying me for months now. I didn’t have skype add in, tried clearing clipboard, temp files, etc that I found on other forums. I’m running on excel 2010 using windows 7 64 bit and kept getting the error message, I solved it by disabling the “one note” add in on internet explorer 9. Hope this helps others
Jean K
I had a problem with MS Excel 2010 getting the error “The clipboard cannot be emptied. Another program might be using the clipboard.”, which I eventually fixed by killing Bing Desktop.
Lynda R
I got mine fixed by uninstalling the Skype adding in Chrome.
Steve J
Thanks for the reports above. I was having the same issue with Excel 2010 on Win7Pro. Deleted the Skype add-on in Internet Explorer. Issue resolved.
Pete M
Thanks for the great forum. I disabled the Skype add-in for Chrome and it fixed it. Eureka!
Ron V
YES IVE BEEN WORKING ON THIS FOR A COUPLE OF DAYS LOOKING AT EVERYONES LINKS AND SOLUTIONS. WHAT I DID WAS THIS…
open google chrome, click on the customize button on the far right top, then click on the settings button. in the setting click on extensions. in the extensions you should see the skype call button enabled. uncheck that. dont need to remove it. just uncheck. i dont use skype on this computer so dont know how this effects anyone who does. seems you cant be online with chrome and excell at the same time with out getting the message. what skype does is post the number of the business or place that is on the web page you are visiting and its an obviuse paste.
hope this works for you
Holly S
Spot on… just tried this and Skype is the culprit
Pat C
Fabulous. Disabled Skype in IE and problem solved. Thank you! This has been annoying me for months!
Gary B
Thank you so much for solving this annoying warning caused by Skype!
Robin Q
Disabling the Skype add-in for Chrome worked for me. Thank you!
Marge C
Try to exit from babylon dictionnary
Melinda A
I had the same issue, and closing Outlook fixed it.
Robert J
It might be Outlook causing the glitch, I haven’t got it since closing Outlook.
WRWY
To help us troubleshoot your problem, which version of Excel are you running?

There’s a couple things that might be interfering with your Excel cell dragging function.

If you’ve been using Remote Desktop, you may get the cannot copy to clipboard error because Remote Desktop uses the clipboard and it can cause weird issues with Excel.

Are you using Remote Desktop? If so, use Ctrl + Alt + Del to open your process manager and kill the rdpclip.exe process. Check any other type of remote desktop applications, VNC applications, download managers, etc. – or any application that might be “monitoring” your clipboard. Disable those and see if you still experience the problem.

In other words – try rebooting your PC, killing unnecessary background processes, and then running only Excel and see if the problem recurs. If it does, the error is happening within Excel and is unrelated to third party software.

In that case, try, within Excel, browsing to Tools > Options > Calculation and selecting “Automatic.”

If you’re running Excel 2003 or earlier, you can also try browsing to Edit > Office Clipboard > “Clear All” to clear the Clipboard. Also, select “Options” and choose “Collect without showing office clipboard.”

Please let us know if any of these suggestions helped!

Robert J
OK .. I was the anonymous post. I’ve now registered so I can subscribe to this post. Any help with this “clipboard cannot be emptied” issue would be great.
Harold Y
I’m getting the same error. But not when I copy in Excel. Just when I drag one cell to move it to another cell. I get the error “The clipboard cannot be emptied. Another program might be using the clipboard. And it’s not every single time. It happens once out of every 2 or 3 times I drag a cell.

I only have a single cell selected. Any help would be appreciated!

Judy B
This usually happens if you try and copy two cells at the same time. Hit the ESC (Escape) key and see if that clears the cell, then try copying again. You may also need to access your clipboard directly and clear it.