Could not load file or assembly MOM.implementation

There are many rumors going around about a MOM.exe spyware application. While there is one that exists, in most cases, the error message you’re seeing about mom.implementation or mom.exe errors is related to your ATI graphics card. That being said, if you’re not using an ATI graphics card, then you may indeed be infected with spyware. If that’s the case, we recommend cleaning your PC with the free Spybot Search & Destroy anti-spyware software.

The “mom.exe failed to initialize” and similar errors are tied to ATI graphics cards, particularly installations of the Catalyst Control Center, and most often occur when a user installs only .NET framework 2.0. To resolve this error, simply download and install .NET framework 1.1 as well. You’ll also want to make sure that you are using the latest graphics drivers for your ATI card.

If, after installing .NET 1.1 you are still getting the error, re-install your Catalyst drivers.

Where do I find new ATI Catalyst drivers?

Since ATI was recently purchased by AMD, you’ll need to visit the AMD website, and then browse in the following direction to find your Catalyst drivers:

  • Under Support, click on Graphics Drivers
  • Select your Operating System, followed by your Graphics Adaptor, followed by your Graphics Card Model
  • Click on GO
  • You’ll be taken to a page that will give you access to the latest Catalyst Software Suite, and (optional), the latest ATI Multimedia Software

You’ll want to completely uninstall your old ATI and Catalyst drivers, but before you do this, it’s important that you find your original ATI CD – it has a tracking feature you’ll need (ie. you’ll need to insert the CD during installation) to be able to install certain ATI drivers. Once you’ve confirmed that you have the CD:

  • Uninstall the old ATI and Catalyst drivers
  • Restart your PC
  • Download the suite software listed above
  • Install the software components in order, beginning with the core graphics card drivers
  • Install the optional ATI Multimedia Software
  • Restart your PC (you may need to do this between each software component)

Once you’ve done this, you should no longer be seeing mom.implementation or mom.exe errors.

Still Seeing the Mom.Implementation and Mom.exe Errors?

If you still can’t get rid of these errors, make sure you’ve run the Spybot Search & Destroy full system scan we mention above. If it finds nothing, and you’re still getting errors, make sure you’ve uninstalled all “ATI” related software. If you did that, rebooted your PC, and you’re still seeing the error message, please post below with details of your problem, including your PC, operating system, and anything else you can think of and we’ll do our best to help!

Know the answer? Comment below! Got your own question? Ask it here.

Leave a Reply

newest oldest most voted
Thank you. This mom error has been unsolvable. Now it’s gone. 🙂
My error message says: Could not load file or assembly ‘CLI.Implementation, Version=2.0.3405.36820, Cultures neutral, PublicKeyToken=90ba9c70f846762e’ or one of its dependencies. The system cannot find the file specified.

What can I do now? I have Windows 8 cp x64 ati radeon hd 4350 cpu intel E5300 2.62Ghz.

Same problem here. I’ve tried re-installing Windows four times a day, re-installing programs, and no luck. I create a restore point everytime I install a new program, and I don’t get any error messages. Right now the issue occurs whenever I install a mouse driver (Cyborg rat 7).

I’ve asked for ATI support via email, and they give me the same solution you mention here, but it doesn’t work for me. My BattleField 3 game refuses to start, so I need to restore my PC to an earlier time after installing Bittorrent or uTorrent.

ATI sucks. My system specs are ATI Radeon HD 5970, Intel Core 2 Extreme Q9650, Asus P5G41-M LX, 4GB ram. I’ll never buy an ATI video card again.

WinVista Basic 32 here, ATI Radeon X1250 on Compaq 6715s notebook. I installed FreeCad software that wouldn’t run with my old drivers, so I installed the newest drivers for my card and the display manager (from Catalyst 10.12 package, as advised by ATI home page). I had to get rid of the “Could not load file” error using the advice above. The FreeCad issue was solved, but the display manager wouldn’t run anymore, so I had to switch back to the previous version of the manager (keeping the new driver) with a lot of restarts and cleaning of registry and files as described above, no joy.

The Win Device Manager wrongly reports ATI Radeon X1200 now. Using its update option keeps the manager from working, again, so I had to rollback. I leave it like that, everything works fine now, but again, no joy.

Only thing that worked for me was to do a clean uninstall of CCC:

Check registry location to be empty. (START > RUN > and type regedit or reget32)
Check (Program Files folder )/ATI Technologies/ATI.ACE to be empty
Check (Windows folder)/Assembly to see if there’s any files with Public Key Token of “90ba9c70f846762e”. Sort by Public key token to get a easier view. All these should be uninstalled by right click and uninstall.
Check (Document and Settings)/(User)/AppData/Local/ATI/ACE to be empty
Make sure you have the correct version of Dot net installed. This one works for sure. The compact one downloaded from MS don’t work.
\90tctac01Tools$Installation KitsDotNet20.r1
Reinstall CCC.

Note: – Sometimes even doing this won’t work on some system. In that case, remove and re-install .Net 2.0 after step 4 above.”

So true. And if you ask anything too difficult in their forums they’ll delete your message.
After spending an entire evening trying all the different posted instructions for getting rid of the MOM. error, FINALLY a solution that worked. Just disabling the startup for ATI stuff…. I’ve been installing / uninstalling every version of .NET, ATI drivers, CCC, etc. I’ve searched for any possible way to communicate with ATI (no luck)… I’m done with ATI forever. I just went and bought an Nvidia GTX 260 to replace my Radeon 5770. Thanks ATI (for nothing).
If you have a Dell PC, whatever you do don’t try to call them. They are useless. I’ve been transferred 7 times so far about the issue and nobody seems to know what I’m talking about.

Final hold time: 55 minutes.

Worst customer service. Downright unbelievable. 🙁

The solution at the top of the page basically worked; however, the process did not work with my Radeon HD 3200 and its original installtion CD. I had to download new drivers. Solutions for the “no compatible hardware found” error for AGP cards are available at the ATI support site.

I think the solution offered above “much easier than that” would remove the error message, but disable the drivers and my second HD display.

I uninstalled the ATI Display Driver and the ATI Catalyst Control Center (control panel – Add Remove Programs) then rebooted and canceled the Windows attempt to install my new hardware. I downloaded and installed the Catalyst Software Suite and rebooted again.

No more errors, my ATI control app is back in the application tray and life is good once more with streaming video on my extended display Vizio 42″ HD!

I tried the .net 1.1 installation trick – it did nothing useful.

Try this:



goto the STARTUP tab

unclick any and all ATI Catalyst tick boxes

Close, re-boot

Voila !!!

Just like that.

PS, my first and last ever ATI card – its going to be replaced by my trusty GeForce Nvidia card, those have always worked for me. ATI is just too much damn trouble to be of any use.

It’s been months since I’m stuck with this problem in Vista x64. I had to download a fix from MS for the VS2005 C++ runtime.

With this, I was finally able to run the Catalyst installed package and update the video driver, but nothing to do as far as the Catalyst installation is concerned. If you look up the MOM.Implementation error on the Internet, it’s amazing how many people are having this problem. ATI simply doesn’t care.

Great software thanks for the tip. It is amazing how this software operates. Its so easy to take screen shots, add photo effects using the layer philosophy, and host images!